Quick Start Guide:

ChemSense Studio Client
Version 3.0.7

January 5, 2005

Comments/Questions/Bug Report?
E-mail: chemsense-contact@ctl.sri.com

Background

The ChemSense Studio Client software supports the sharing, viewing, and editing of a
variety of chemistry representations, including text, images, drawings, and animations of
chemical processes. The software consists of a client, which views and edits files, and a
server, where items are stored. You need an Internet connection and login account to use
the ChemSense Studio Client.

Contents of This Guide

This introductory guide covers the following information:

General:
* Installing the ChemSense Studio Client
* Logging in
* Connection options
* Viewing items
* (Creating new items
* Editing and saving items
* Commenting on items
* Searching for items

Specific Tools:
* Periodic tables
e Text tool
* Image tool
* Draw tool
* Animation tool
* Graph tool
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Installing the ChemSense Studio Client

The ChemSense Studio Client can be downloaded at http://chemsense.org/download
Using a web browser, down the installer for your platform (ChemSense software is
available for Windows and Mac OS X), and run the installer.

The installer will prompt you for where you would like to install the software, and will
place a shortcut on your desktop. When the installer completes, launch the ChemSense
Studio by double-clicking on the application or the shortcut icon.

Logging In

When you launch the ChemSense Studio, you will be prompted for a username and
password. You can get these values from your instructor (see Figure 1).

Note that for security reasons, login sessions expire after a few hours. If your session
expires, you will be prompted to log in again before you can save your work. For your
security, do not leave the client running on a computer that others have access to when
you are not present.

x|

@ Erter login information, or Cancel to exit.

IJzername:; mat! 14

Paszward EEEEEEEE

Optionz... |

Ok Cancel |

Figure 1. ChemSense Studio login dialog.

Connection Options

Under the Options button you can tell ChemSense Studio to remember your password,
set proxy server values (if applicable), and change the URL for the ChemSense server
you are connecting to (e.g., if you are running a local server in your classroom, or as a
stand-alone demo on your computer).

Note: Don't check Save Password unless you are on a private machine that others
cannot access, or unless instructed to do so by your teacher.
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Figure 2. Connection options.
Verify that the value for the ChemSense Server URL is correct. This is the URL of
the server on which your login account exists. If it is incorrect, you will not be able to log

in. You may need to ask your instructor for the value that you should use.

* Ifyou have an account on SRI’s ChemSense server, the value should be
http://server.chemsense.sri.com

* Ifyou are running your own local ChemSense server on the same machine as the
ChemSense Studio, the value should be http://localhost:8080

* Ifyou have a local network in your classroom with one computer running the
ChemSense server, the value should be

http://the.ip.address.of . your.classroom.server:8080

Viewing Items

After you log in, a large window will appear on your screen (see Figure 3). The window
is divided into two main frames.

1. The left frame is the navigation frame, called the explorer tree. It contains folders
called groups. A group can contain other groups, as well as individual user
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accounts, represented by a person icon. Each individual account contains items
created by that user.

2. The right frame is the workspace, where you can create and edit items you own,

and view and comment on items created by others.
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Figure 3. The explorer (left) and workspace (right).

When you first log in, the explorer tree will expand to show you the items that you own.
After that, you can click on any * icon to expand another group (to see subgroups and
users) or to expand another user (to see his or her items). Click the = icon to collapse or
hide part of the explorer tree.
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When you expand a user or group for the first time, the ChemSense Studio Client makes
a request over the network to the ChemSense server to retrieve the items for display.
Depending on the speed of your connection, you may notice some lag the first time you
expand a user or group.

To view an item created by a user, double click it, or select it and press enter, or choose
View selected from the File menu. The item will open in the workspace area on the
right. To edit an item you own, select it in the explorer tree and choose Edit selected
from the File menu (or Control-E). For example, if we edit the "Dissolving Process"
item, an animation opens in workspace area (see Figure 3). If the animation is large, it
may take a few seconds to transfer over the network from the ChemSense server to your
computer.

If you want more workspace area, you can temporarily hide the explorer tree by
unselecting Show Explorer in the Windows menu. You can also gain more space by
hiding the comment pane on items (see below); to do this, unselect Show Comments
in the Windows menu.

Creating New Items
To create a new item, select New Item from the File menu (or Control-N). You may
have noticed by now that most menu items have keyboard shortcut alternatives; just look

at the menu item to see the shortcut. When you create a new item, a dialog will appear
prompting you to choose the type of item you want to create (see Figure 4).

X|

Create new item of type:

T H i Ed £ =
Text HTML Graph Image Dranving Anirnation
Cancel

Figure 4. Create a new item dialog.
There are six types of items you can choose from:

1. Text tool, for unformatted text.

HTML tool, for (very basic) formatted HTML text.

Graph tool, to enter data values into a table or import data from a file to create an
X-y graph.

4. Image tool, if you have a local image (e.g., JPEG or GIF) that you want to import
into the ChemSense Studio for other to see.

Drawing tool, to create a static drawing.

6. Animation tool, to create a sequence of drawings for a storyboard animation.

bl

N

Copyright 1999-2005 SRI International. All Rights Reserved. 5



The animation and drawing tools are used most often!
Editing and Saving Items

When you create a new item, an edit window will appear. When you edit an item that you
created earlier, you will see the same edit window.

This edit window is divided into two parts (see Figure 5).

1. The upper frame, where you edit the content of the item and give it a title. Only
you can edit these parts of an item you create.

2. The lower frame, where you, or anyone else who can see your item can also add
comments about it.

' Questions of NaCL I [=] |
File  Edit

a)What characteristic about each of these substances allowes them to make a solution?
Each substance iz an ionic compound, S0 when mixed together they can create a solution.
kb1 Do all ionic substances make salutions with seater? Whyy ar why not?

Yes, because water iz polar and ionic compounds contain bath negative and positive
atams, sa their atoms would be attracted to the opposite charge of the water molecule

Title: Fluestiu:uns of MaClL m
F
'k at do you think™® Add comments by typing in the field below) —I

I
Add Comment

Figure 5. Editing the content and title of a text item (top) and comment area. Only the
owner can edit the content and title, but anyone can add comments.

To save an item, press the Save button, or select Save from the File menu of the item
you are editing (or Control-S). When you save the item, it will appear in the list of items
under your account.
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When you save, the ChemSense Studio sends the contents over the network to the server
for storage. Depending on the speed of your network connection and the size of your
item, you may notice some delay when you save an item.

You can later edit any item that you created by selecting it and choosing Edit selected
from the File menu (Control-E), or right-click on the item and choose Edit from the
popup-menu. Note that you can only edit items that you created; you cannot edit items
created by others

Commenting on Items

When you are editing one of your items or viewing items created by others, you will
notice an area at the bottom where you can post comments about the item. Anyone in
your group can comment on your item, and similarly, you can view someone else’s item
and comment on it using this feature (see Figure 6.)

patti: *our animation is good, but the ions should form charges before they hook up into ;I
an ionic compound (20030830 2335 35)

i
| like your narration, too Add Comment

Figure 6. Adding a comment to an item.

If you can view an item, you can read all comments made on it. Note that you can’t delete
a comment once you have posted it, and your name (and the time) is automatically posted
along with the comment when you press the Add Comment button. So remember,
comment carefully; your comments are public and you can’t edit or delete the later!

You can temporarily hide comments by unselecting Show Comments from the
Windows menu.

Searching for Items
In addition to navigating through the explorer tree to find items, you can search for items
by title (see Figure 7). To do so, click on the Find (magnifying glass) button in the upper

right corner of the ChemSense Studio, or select Find from the File menu.

To search by title, type in a title, and press return or the Find button. All titles matching
the search string will be returned.

To view an item in the search result list, just double-click it. To edit an item that you own

in the list, select the item and choose Edit from the search window's File menu, or right-
click on it and choose Edit from the pop-up menu. You must own the item to edit it.
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Figure 7. Searching for items by title.

Periodic Tables

Two Periodic Table tools are available via the small buttons at the upper right of the
application, or via the Windows menu (see Figure 8). Select either the large or small
periodic table, and move your mouse over an element for more information about that
element (i.e., full name, atomic number and weight).

Copyright 1999-2005 SRI International. All Rights Reserved.



Periodic Table
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Figure 8. Large and small Periodic Table tools.
Text Tool
The Text tool is a simple, plain text editor like NotePad on Microsoft Windows (see
Figure 5 above). It supports cut, copy and paste, import from local files, and export to
local files. Cut, copy and paste work across different applications on your computer, so
you can transfer text to and from a ChemSense Studio note and another application (like
Word or a web page).
Image Tool

The image tool lets you import an image from local storage to make it available to others.
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To import an image, create a new image item and select Import Image from the File
menu of the image item (see Figure 9). Three standard image formats are supported for
import: GIF, JPEG, PNG.

You can export an image to a local file via the export menu items. Two image formats are
supported for export: JPEG and PNG. GIF is a proprietary format that requires licensing
to generate; PNG is an open format that is replacing the proprietary GIF standard on the
Internet.

You can use this tool to import any images you want to share with others, and to export
images that you may want to use elsewhere, like in a web presentation.

'E Aspirin
File
Save Ctrl+5

Impaort mage. ..

Export JPEG...
Export PHG...

Print...

Title: |A=pirin m

Figure 9. Image tool (with comment area hidden).

Draw Tool

The Draw Tool lets you draw two-dimensional structural representations of chemical
phenomena (see Figure 10).

It consists of a toolbar of shapes (left), an canvas drawing area (right), various color tools
for the outline and fill color of shapes (top), and a menu with options for duplicating,
moving, layering, grouping, and otherwise modifying selected shapes. Multiple levels of
undo/redo are also supported.
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ChemSense drawings can be exported as a JPEG or PNG image for the Web, or in XML
format for local backups. Drawings exported in XML format also can later be imported
(from XML format).
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Figure 10. Drawing tool (with comment area hidden).

To draw a shape, select a tool and click on the white canvas to "stamp" the shape. Some
tools, like the bond/line tool and arrow tool, can be dragged before you release the mouse
(e.g., to draw a line in the desired direction).

The selection tool h'I* (top left) can be used to select a shape or group of shapes on the
canvas. When a shape is selected, a rectangular border is drawn around it to indicate the
selection. Once a shape or group of shapes is selected, you can move, rotate, resize, color,
relayer, nudge, duplicate, or group them.

To move a shape, click on it and drag it to a new position. To just nudge it a little in one
direction, select it and press the arrow keys, or select Nudge from the Arrange menu.

To bring a shape forward or move it behind another shape, select it and use the move
layer options in the Arrange menu.

To resize a shape, select the shape, look for a tiny white square that appears in the lower-
right corner, and drag this corner to a new position.
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To rotate a shape, select the shape, look for a tiny yellow circle that appears in the upper-
right corner, and drag this circle to a new position.

To change the outline color of a shape, select the Pen button, select the shape, and click
on a new color in the color bar. To change the fill color, select Fill instead of Pen, and
repeat these steps.

To duplicate a shape, select it and choose Duplicate from the Edit menu. Note that
many menu item options have keyboard shortcuts, as specified on the menu item.

The Text tool T accepts and displays multiple lines of text (press the Enter or Return
key when editing text to begin a new line). It also uses a few simple rules to parse the text
that you enter to display any subscripts and superscripts on chemical formulas. For
example, if you type:

NH4 + Cl-
in the text edit window and then click on the canvas, the following will be displayed:
NH,4 + CI'

That is, the 4 will be subscripted and the '-' will be superscripted. Note that you must type
a space before and after the “+’ if you do not want it to be interpreted as a superscript. A
plus (“+’) or minus (‘-°) immediately following a letter or number (no space) will be
automatically superscripted, and a number immediately following a letter (no space) will
automatically be subscripted. Anything following a space or equals sign (‘=) is always
displayed in normal type, neither subscripted nor superscripted.

If you want to force a word to be superscripted, type a ‘“*’ character before it; if you want
to force it to be subscripted, type a ‘|’ character before it. For example, if you enter:

This should be “superscripted
This should be |subscripted

Then when you click on the canvas you will see:

This should be S'Perscripted

ThiS ShOUld be subscripted
Finally, to edit existing text, just double-click on the text and enter your changes in the

dialog that appears. To later change the font size, style, or family, select the text shape
and use the Font menu to choose new values.
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Animation Tool

The Animation tool lets you create multiple frames of a drawing to create a storyboard
animation (see Figure 11). The animation window is divided into two parts:

1. The top part of the Animator window contains a drawing area where you can
draw and edit individual frames.

2. The bottom part of the window contains the animator controls. The controls
consists of a filmstrip to interact with the frames, sliders and buttons (immediately
below the filmstrip) to step through, play, and add frames, and a duration slider to
specify the amount of time spent on the selected frame.

Copyright 1999-2005 SRI International. All Rights Reserved. 13



o

A Dissoling Process
Edit Arrange Font  Anirmation Pen: M| ] Fi: O Flone]

OO |18 ¢ S| Z @

Title:

Ma atams being pulled off by H, O

[ 2]
FEEETgE

Llﬂﬂ —J— 3 Add Frame | Frame Speed: —J— 5

izsolving Process m

Figure 11. Animation tool (with comment area hidden).

To create an animation, first make a drawing of the initial frame. To create a second
frame, press the Add Frame button. This will copy the contents of the current frame into

a new frame, which you can then edit to change. Continue in this fashion for each new

frame you want to create.

To scroll the film, move the slider just below the film strip, or step forward and backward

one frame at a time using step forward ™ and step backward ™ buttons. You can
mouse over a frame on the film strip to see the frame number.
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To edit an existing frame, just click on the frame in the film strip (scroll the film if
necessary) and make your edits to that frame.

To delete a frame, select it and choose Delete Selected Frame from the Animation
menu. To delete all frames, choose Delete All Frames from the Animation menu. To
change the duration of a frame, select the frame and adjust the Frame Speed bar (far
right, below the film strip).

To play an animation, press the play > button on the far left. If you want the animation
to loop over and over again when it plays, select Loop Animation in the Animation

menu. You can hide the film strip by unselecting Show Film Strip in the Animation
menu.

To export an animation for use outside of the ChemSense Studio (e.g., in a Web page),
select Export Animation to Animated GIF' or Export Animation to Quicktime?
in the File menu. To play the exported animation, just open it with a web browser or with
Quicktime. You can download Quicktime for free on the Apple web site.

The File menu also lets you export and import animations as XML. Use this to create
local backups of animations you have created (if desired), or to copy an animation to a
new document (e.g., export it, create a new animation item in ChemSense, and import the
animation that just exported).

Graph Tool
The graph tool lets you create and view X-Y plots of data (see Figure 12). The data table

(left) contains the X-Y coordinates for a selected series. The graph (center) plots one or
more series or "runs" of data as specified in the data table.

" On Mac OS X, there appears to be an incompatibility in the current Java
implementation (1.4.2) when producing an animated GIF, so Mac OS X users should use
Quicktime export for the time being.

* On Microsoft Windows, you must first do a custom install of Quicktime be able to
export animations to Quicktime. This custom installation is described in the README
file that comes along with the installation. In brief, you have to install Java (if it’s not
already installed), download and launch the Quicktime installer, choose Custom for
Installation type, and check Quicktime Essentials (1st item, should be selected by
default), Quicktime Internet Extras (2nd item), and QuickTime for Java (2nd to last
item; scroll down to it). If you are using Mac OS X, you don’t need to do a custom
installation; Quicktime and Java are already installed on Mac OS X, and will just work.
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Figure 12. Graph tool (with comment area hidden).

To edit a cell value, click on the cell to select it. You should see a faint yellow box
outlining the cell. When a cell is selected, you can edit it directly by pressing the
backspace key to delete what is there and typing in a new number. The Tab key can also
be used to move to (select) the next cell. Use Shift+Tab to move to the previous cell. The
up and down arrow keys will also move you between cells in a column. Whenever a cell
is selected in one of these ways, you can edit it by pressing the backspace key and
retyping the number that is there.

To add a new row to the bottom of the current series, select Add New Row from the
Edit menu. The new row added at the bottom will contain default data values that you
can select and edit.

To insert a new row in the middle, select a row (click your cursor in a cell in the row) that

you want to insert above, and select Insert New Row from the Edit menu. To delete a
row, select a row and then select Delete Selected Row.
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To add an entire new series of data, select Add New Series from the Edit menu. A new
series will be added to the table, and selected by default. To move between series, use the
Series popup menu above the table. To delete the current selected series, select Delete
Selected Series from the Edit menu.

To edit the labels on the X and Y axes and the title shown above the graph, select Graph
Labels... from the Edit menu and enter new values.

To export an image of your graph, select Export JPEG or Export PNG from the File

menu. You can also export and import graph XML descriptions as well as tab-delimited
data via the File menu.
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